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Eclipse: elementi strutturali 1
1) workspaceworkspaceworkspaceworkspaceworkspaceworkspaceworkspaceworkspaceworkspace: directory principale di lavoro, al 
suo interno Eclipse crea, di default, tutte le altre 
directory e le “risorse” (file *.java, *.class, 
.classpath, .project)

2) workbenchworkbenchworkbenchworkbenchworkbenchworkbenchworkbenchworkbenchworkbench: ambiente desktop di sviluppocon 
tool per la creazione e la modifica delle risorse e 
la visualizzazzione della struttura a vari livelli di 
astrazione

3) vistevistevistevistevistevistevistevisteviste (views) ed editoreditoreditoreditoreditoreditoreditoreditoreditor: le viste contengono 
varie “rapprsentazioni” mentre gli editor 
consentono la stesura e la modifica del codice



  

Eclipse: elementi strutturali 2
1) vistevistevistevistevistevistevistevisteviste: permettono di esplorare le risorse a vari livelli 
(package, file system) e di interagire con il codice (Problems, 
Declaration, Console...). Lavorando sulle vistesi ha un 
salvataggio automatico degli effetti delle operazioni

2) editoreditoreditoreditoreditoreditoreditoreditoreditor:

a)creazione del codice

b)modifica del codice

c)correzione del codice

d)esecuzione del codice

e)ciclo apri-salva-chiudi

f)compilazione dinamica: segnalazione di errori sintattici 
in tempo reale.



  

Eclipse: elementi strutturali 3

1) perspectiveperspectiveperspectiveperspectiveperspectiveperspectiveperspectiveperspectiveperspective: definiscono l'insieme iniziale e la 
posizione relativa delle views nel workbench 

2) Window -> Open Perspective -> JavaWindow -> Open Perspective -> JavaWindow -> Open Perspective -> JavaWindow -> Open Perspective -> JavaWindow -> Open Perspective -> JavaWindow -> Open Perspective -> JavaWindow -> Open Perspective -> JavaWindow -> Open Perspective -> JavaWindow -> Open Perspective -> Java

3) Window -> Open Perspective -> Java BrowsingWindow -> Open Perspective -> Java BrowsingWindow -> Open Perspective -> Java BrowsingWindow -> Open Perspective -> Java BrowsingWindow -> Open Perspective -> Java BrowsingWindow -> Open Perspective -> Java BrowsingWindow -> Open Perspective -> Java BrowsingWindow -> Open Perspective -> Java BrowsingWindow -> Open Perspective -> Java Browsing

4) Window -> Customise Perspective ...Window -> Customise Perspective ...Window -> Customise Perspective ...Window -> Customise Perspective ...Window -> Customise Perspective ...Window -> Customise Perspective ...Window -> Customise Perspective ...Window -> Customise Perspective ...Window -> Customise Perspective ...

5) definizione elementi del Workbench

➢) Window -> Show ViewWindow -> Show ViewWindow -> Show ViewWindow -> Show ViewWindow -> Show ViewWindow -> Show ViewWindow -> Show ViewWindow -> Show ViewWindow -> Show View



  

Eclipse: viste importanti
         Package Explorer: codice java, segnalazione errori, link ai Package Explorer: codice java, segnalazione errori, link ai Package Explorer: codice java, segnalazione errori, link ai Package Explorer: codice java, segnalazione errori, link ai Package Explorer: codice java, segnalazione errori, link ai Package Explorer: codice java, segnalazione errori, link ai Package Explorer: codice java, segnalazione errori, link ai Package Explorer: codice java, segnalazione errori, link ai Package Explorer: codice java, segnalazione errori, link ai 
metodi delle classi;metodi delle classi;metodi delle classi;metodi delle classi;metodi delle classi;metodi delle classi;metodi delle classi;metodi delle classi;metodi delle classi;

 “ “ “ “ “ “ “ “ “Espansione” delle risorse ed accesso ai metodi mediante Espansione” delle risorse ed accesso ai metodi mediante Espansione” delle risorse ed accesso ai metodi mediante Espansione” delle risorse ed accesso ai metodi mediante Espansione” delle risorse ed accesso ai metodi mediante Espansione” delle risorse ed accesso ai metodi mediante Espansione” delle risorse ed accesso ai metodi mediante Espansione” delle risorse ed accesso ai metodi mediante Espansione” delle risorse ed accesso ai metodi mediante 
selezione. Da Outline solo per il file correntemente in “primo selezione. Da Outline solo per il file correntemente in “primo selezione. Da Outline solo per il file correntemente in “primo selezione. Da Outline solo per il file correntemente in “primo selezione. Da Outline solo per il file correntemente in “primo selezione. Da Outline solo per il file correntemente in “primo selezione. Da Outline solo per il file correntemente in “primo selezione. Da Outline solo per il file correntemente in “primo selezione. Da Outline solo per il file correntemente in “primo 
piano” come editorpiano” come editorpiano” come editorpiano” come editorpiano” come editorpiano” come editorpiano” come editorpiano” come editorpiano” come editor

         Navigator: struttura del file system;Navigator: struttura del file system;Navigator: struttura del file system;Navigator: struttura del file system;Navigator: struttura del file system;Navigator: struttura del file system;Navigator: struttura del file system;Navigator: struttura del file system;Navigator: struttura del file system;

         Link with editor  (Link with editor  (Link with editor  (Link with editor  (Link with editor  (Link with editor  (Link with editor  (Link with editor  (Link with editor  (←→←→←→←→←→←→←→←→←→sovrappostesovrappostesovrappostesovrappostesovrappostesovrappostesovrappostesovrappostesovrapposte) per portare in primo ) per portare in primo ) per portare in primo ) per portare in primo ) per portare in primo ) per portare in primo ) per portare in primo ) per portare in primo ) per portare in primo 
piano l'editor di un file, lo stesso  in Package Explorer;piano l'editor di un file, lo stesso  in Package Explorer;piano l'editor di un file, lo stesso  in Package Explorer;piano l'editor di un file, lo stesso  in Package Explorer;piano l'editor di un file, lo stesso  in Package Explorer;piano l'editor di un file, lo stesso  in Package Explorer;piano l'editor di un file, lo stesso  in Package Explorer;piano l'editor di un file, lo stesso  in Package Explorer;piano l'editor di un file, lo stesso  in Package Explorer;

         Console: interazioni con il codice (display, input da Console: interazioni con il codice (display, input da Console: interazioni con il codice (display, input da Console: interazioni con il codice (display, input da Console: interazioni con il codice (display, input da Console: interazioni con il codice (display, input da Console: interazioni con il codice (display, input da Console: interazioni con il codice (display, input da Console: interazioni con il codice (display, input da 
tastiera);tastiera);tastiera);tastiera);tastiera);tastiera);tastiera);tastiera);tastiera);

         Problems: errori del codice, tre colonne: Description (degli Problems: errori del codice, tre colonne: Description (degli Problems: errori del codice, tre colonne: Description (degli Problems: errori del codice, tre colonne: Description (degli Problems: errori del codice, tre colonne: Description (degli Problems: errori del codice, tre colonne: Description (degli Problems: errori del codice, tre colonne: Description (degli Problems: errori del codice, tre colonne: Description (degli Problems: errori del codice, tre colonne: Description (degli 
errori), Resource (file .java) e Path (package)errori), Resource (file .java) e Path (package)errori), Resource (file .java) e Path (package)errori), Resource (file .java) e Path (package)errori), Resource (file .java) e Path (package)errori), Resource (file .java) e Path (package)errori), Resource (file .java) e Path (package)errori), Resource (file .java) e Path (package)errori), Resource (file .java) e Path (package)

Declaration: visualizza la struttura dei metodi contenuti in Declaration: visualizza la struttura dei metodi contenuti in Declaration: visualizza la struttura dei metodi contenuti in Declaration: visualizza la struttura dei metodi contenuti in Declaration: visualizza la struttura dei metodi contenuti in Declaration: visualizza la struttura dei metodi contenuti in Declaration: visualizza la struttura dei metodi contenuti in Declaration: visualizza la struttura dei metodi contenuti in Declaration: visualizza la struttura dei metodi contenuti in 
altri file .java (come Input.java)altri file .java (come Input.java)altri file .java (come Input.java)altri file .java (come Input.java)altri file .java (come Input.java)altri file .java (come Input.java)altri file .java (come Input.java)altri file .java (come Input.java)altri file .java (come Input.java)



  

Eclipse: Java perspective

1)1)1)1)1)1)1)1)1)         File -> New -> ProjectFile -> New -> ProjectFile -> New -> ProjectFile -> New -> ProjectFile -> New -> ProjectFile -> New -> ProjectFile -> New -> ProjectFile -> New -> ProjectFile -> New -> Project

controllare Preferences -> Java -> Compiler compliance level controllare Preferences -> Java -> Compiler compliance level controllare Preferences -> Java -> Compiler compliance level controllare Preferences -> Java -> Compiler compliance level controllare Preferences -> Java -> Compiler compliance level controllare Preferences -> Java -> Compiler compliance level controllare Preferences -> Java -> Compiler compliance level controllare Preferences -> Java -> Compiler compliance level controllare Preferences -> Java -> Compiler compliance level 
5.05.05.05.05.05.05.05.05.0

Java Project +Next >Java Project +Next >Java Project +Next >Java Project +Next >Java Project +Next >Java Project +Next >Java Project +Next >Java Project +Next >Java Project +Next >

Project Name LIP-ES-# + valori default + FinishProject Name LIP-ES-# + valori default + FinishProject Name LIP-ES-# + valori default + FinishProject Name LIP-ES-# + valori default + FinishProject Name LIP-ES-# + valori default + FinishProject Name LIP-ES-# + valori default + FinishProject Name LIP-ES-# + valori default + FinishProject Name LIP-ES-# + valori default + FinishProject Name LIP-ES-# + valori default + Finish

2)2)2)2)2)2)2)2)2)         il progetto creato compare nelle viste:il progetto creato compare nelle viste:il progetto creato compare nelle viste:il progetto creato compare nelle viste:il progetto creato compare nelle viste:il progetto creato compare nelle viste:il progetto creato compare nelle viste:il progetto creato compare nelle viste:il progetto creato compare nelle viste:

Package Explorer, NavigatorPackage Explorer, NavigatorPackage Explorer, NavigatorPackage Explorer, NavigatorPackage Explorer, NavigatorPackage Explorer, NavigatorPackage Explorer, NavigatorPackage Explorer, NavigatorPackage Explorer, Navigator



  

Eclipse: Java class
1)1)1)1)1)1)1)1)1)         File -> New -> ClassFile -> New -> ClassFile -> New -> ClassFile -> New -> ClassFile -> New -> ClassFile -> New -> ClassFile -> New -> ClassFile -> New -> ClassFile -> New -> Class

controllare progetto selezionato, se no Browse...controllare progetto selezionato, se no Browse...controllare progetto selezionato, se no Browse...controllare progetto selezionato, se no Browse...controllare progetto selezionato, se no Browse...controllare progetto selezionato, se no Browse...controllare progetto selezionato, se no Browse...controllare progetto selezionato, se no Browse...controllare progetto selezionato, se no Browse...

Name senza suffisso .javaName senza suffisso .javaName senza suffisso .javaName senza suffisso .javaName senza suffisso .javaName senza suffisso .javaName senza suffisso .javaName senza suffisso .javaName senza suffisso .java

selezionare “public static void main...” per avere il template selezionare “public static void main...” per avere il template selezionare “public static void main...” per avere il template selezionare “public static void main...” per avere il template selezionare “public static void main...” per avere il template selezionare “public static void main...” per avere il template selezionare “public static void main...” per avere il template selezionare “public static void main...” per avere il template selezionare “public static void main...” per avere il template 
del metodo main della classedel metodo main della classedel metodo main della classedel metodo main della classedel metodo main della classedel metodo main della classedel metodo main della classedel metodo main della classedel metodo main della classe

altri valori di defaultaltri valori di defaultaltri valori di defaultaltri valori di defaultaltri valori di defaultaltri valori di defaultaltri valori di defaultaltri valori di defaultaltri valori di default

FinishFinishFinishFinishFinishFinishFinishFinishFinish

si apre un pannello di edit con il file .java appena creatosi apre un pannello di edit con il file .java appena creatosi apre un pannello di edit con il file .java appena creatosi apre un pannello di edit con il file .java appena creatosi apre un pannello di edit con il file .java appena creatosi apre un pannello di edit con il file .java appena creatosi apre un pannello di edit con il file .java appena creatosi apre un pannello di edit con il file .java appena creatosi apre un pannello di edit con il file .java appena creato

il file compare nelle viste Package Explorer, Navigatoril file compare nelle viste Package Explorer, Navigatoril file compare nelle viste Package Explorer, Navigatoril file compare nelle viste Package Explorer, Navigatoril file compare nelle viste Package Explorer, Navigatoril file compare nelle viste Package Explorer, Navigatoril file compare nelle viste Package Explorer, Navigatoril file compare nelle viste Package Explorer, Navigatoril file compare nelle viste Package Explorer, Navigator

nome con * modifiche da salvare, con x in campo rosso errori nome con * modifiche da salvare, con x in campo rosso errori nome con * modifiche da salvare, con x in campo rosso errori nome con * modifiche da salvare, con x in campo rosso errori nome con * modifiche da salvare, con x in campo rosso errori nome con * modifiche da salvare, con x in campo rosso errori nome con * modifiche da salvare, con x in campo rosso errori nome con * modifiche da salvare, con x in campo rosso errori nome con * modifiche da salvare, con x in campo rosso errori 
sintatticisintatticisintatticisintatticisintatticisintatticisintatticisintatticisintattici

il salvataggio comprende la compilazione (creazione dinamica il salvataggio comprende la compilazione (creazione dinamica il salvataggio comprende la compilazione (creazione dinamica il salvataggio comprende la compilazione (creazione dinamica il salvataggio comprende la compilazione (creazione dinamica il salvataggio comprende la compilazione (creazione dinamica il salvataggio comprende la compilazione (creazione dinamica il salvataggio comprende la compilazione (creazione dinamica il salvataggio comprende la compilazione (creazione dinamica 
del file .class, visibile in Navigator ma non in Package Explorer) del file .class, visibile in Navigator ma non in Package Explorer) del file .class, visibile in Navigator ma non in Package Explorer) del file .class, visibile in Navigator ma non in Package Explorer) del file .class, visibile in Navigator ma non in Package Explorer) del file .class, visibile in Navigator ma non in Package Explorer) del file .class, visibile in Navigator ma non in Package Explorer) del file .class, visibile in Navigator ma non in Package Explorer) del file .class, visibile in Navigator ma non in Package Explorer) 



  

Eclipse: Java run
1)1)1)1)1)1)1)1)1)         Run -> Run As -> Java ApplicationRun -> Run As -> Java ApplicationRun -> Run As -> Java ApplicationRun -> Run As -> Java ApplicationRun -> Run As -> Java ApplicationRun -> Run As -> Java ApplicationRun -> Run As -> Java ApplicationRun -> Run As -> Java ApplicationRun -> Run As -> Java Application

esecuzione da menù principaleesecuzione da menù principaleesecuzione da menù principaleesecuzione da menù principaleesecuzione da menù principaleesecuzione da menù principaleesecuzione da menù principaleesecuzione da menù principaleesecuzione da menù principale

esecuzione da menù flottante su tab di editing del file .javaesecuzione da menù flottante su tab di editing del file .javaesecuzione da menù flottante su tab di editing del file .javaesecuzione da menù flottante su tab di editing del file .javaesecuzione da menù flottante su tab di editing del file .javaesecuzione da menù flottante su tab di editing del file .javaesecuzione da menù flottante su tab di editing del file .javaesecuzione da menù flottante su tab di editing del file .javaesecuzione da menù flottante su tab di editing del file .java

esecuzione con combinazione di tasti esecuzione con combinazione di tasti esecuzione con combinazione di tasti esecuzione con combinazione di tasti esecuzione con combinazione di tasti esecuzione con combinazione di tasti esecuzione con combinazione di tasti esecuzione con combinazione di tasti esecuzione con combinazione di tasti 

interazione con vista Consoleinterazione con vista Consoleinterazione con vista Consoleinterazione con vista Consoleinterazione con vista Consoleinterazione con vista Consoleinterazione con vista Consoleinterazione con vista Consoleinterazione con vista Console

input da tastiera in vista Consoleinput da tastiera in vista Consoleinput da tastiera in vista Consoleinput da tastiera in vista Consoleinput da tastiera in vista Consoleinput da tastiera in vista Consoleinput da tastiera in vista Consoleinput da tastiera in vista Consoleinput da tastiera in vista Console

output su video in vista Consoleoutput su video in vista Consoleoutput su video in vista Consoleoutput su video in vista Consoleoutput su video in vista Consoleoutput su video in vista Consoleoutput su video in vista Consoleoutput su video in vista Consoleoutput su video in vista Console

se in processo non termina (cicli while, for, do.. while errati) lo si se in processo non termina (cicli while, for, do.. while errati) lo si se in processo non termina (cicli while, for, do.. while errati) lo si se in processo non termina (cicli while, for, do.. while errati) lo si se in processo non termina (cicli while, for, do.. while errati) lo si se in processo non termina (cicli while, for, do.. while errati) lo si se in processo non termina (cicli while, for, do.. while errati) lo si se in processo non termina (cicli while, for, do.. while errati) lo si se in processo non termina (cicli while, for, do.. while errati) lo si 
può interrompere forzatamente con un pulsante ad hoc (colore può interrompere forzatamente con un pulsante ad hoc (colore può interrompere forzatamente con un pulsante ad hoc (colore può interrompere forzatamente con un pulsante ad hoc (colore può interrompere forzatamente con un pulsante ad hoc (colore può interrompere forzatamente con un pulsante ad hoc (colore può interrompere forzatamente con un pulsante ad hoc (colore può interrompere forzatamente con un pulsante ad hoc (colore può interrompere forzatamente con un pulsante ad hoc (colore 
rosso a destra di Console)rosso a destra di Console)rosso a destra di Console)rosso a destra di Console)rosso a destra di Console)rosso a destra di Console)rosso a destra di Console)rosso a destra di Console)rosso a destra di Console)

si può fare il clear della vista Consolesi può fare il clear della vista Consolesi può fare il clear della vista Consolesi può fare il clear della vista Consolesi può fare il clear della vista Consolesi può fare il clear della vista Consolesi può fare il clear della vista Consolesi può fare il clear della vista Consolesi può fare il clear della vista Console



  

Eclipse: Import...Import...Import...Import...Import...Import...Import...Import...Import... e Export...Export...Export...Export...Export...Export...Export...Export...Export...
1)1)1)1)1)1)1)1)1)         File -> Import...File -> Import...File -> Import...File -> Import...File -> Import...File -> Import...File -> Import...File -> Import...File -> Import...

         rende accessibili i metodi di una classe dall'interno di un'altra;rende accessibili i metodi di una classe dall'interno di un'altra;rende accessibili i metodi di una classe dall'interno di un'altra;rende accessibili i metodi di una classe dall'interno di un'altra;rende accessibili i metodi di una classe dall'interno di un'altra;rende accessibili i metodi di una classe dall'interno di un'altra;rende accessibili i metodi di una classe dall'interno di un'altra;rende accessibili i metodi di una classe dall'interno di un'altra;rende accessibili i metodi di una classe dall'interno di un'altra;

         File -> Import...File -> Import...File -> Import...File -> Import...File -> Import...File -> Import...File -> Import...File -> Import...File -> Import...

         File System + Next >File System + Next >File System + Next >File System + Next >File System + Next >File System + Next >File System + Next >File System + Next >File System + Next >

         From directory + Browse...+selectFrom directory + Browse...+selectFrom directory + Browse...+selectFrom directory + Browse...+selectFrom directory + Browse...+selectFrom directory + Browse...+selectFrom directory + Browse...+selectFrom directory + Browse...+selectFrom directory + Browse...+select

         Into folder: o progetto selezionato o Browse...Into folder: o progetto selezionato o Browse...Into folder: o progetto selezionato o Browse...Into folder: o progetto selezionato o Browse...Into folder: o progetto selezionato o Browse...Into folder: o progetto selezionato o Browse...Into folder: o progetto selezionato o Browse...Into folder: o progetto selezionato o Browse...Into folder: o progetto selezionato o Browse...

         FinishFinishFinishFinishFinishFinishFinishFinishFinish

         metodo alternativo: copia del file nella directory + File -> metodo alternativo: copia del file nella directory + File -> metodo alternativo: copia del file nella directory + File -> metodo alternativo: copia del file nella directory + File -> metodo alternativo: copia del file nella directory + File -> metodo alternativo: copia del file nella directory + File -> metodo alternativo: copia del file nella directory + File -> metodo alternativo: copia del file nella directory + File -> metodo alternativo: copia del file nella directory + File -> 
Refresh... con Package Explorer selezionatoRefresh... con Package Explorer selezionatoRefresh... con Package Explorer selezionatoRefresh... con Package Explorer selezionatoRefresh... con Package Explorer selezionatoRefresh... con Package Explorer selezionatoRefresh... con Package Explorer selezionatoRefresh... con Package Explorer selezionatoRefresh... con Package Explorer selezionato

2)2)2)2)2)2)2)2)2)         File -> Export...File -> Export...File -> Export...File -> Export...File -> Export...File -> Export...File -> Export...File -> Export...File -> Export...

         File System + Next>File System + Next>File System + Next>File System + Next>File System + Next>File System + Next>File System + Next>File System + Next>File System + Next>

         cosa (selezioni) dove (directory destinazione per gli elementi cosa (selezioni) dove (directory destinazione per gli elementi cosa (selezioni) dove (directory destinazione per gli elementi cosa (selezioni) dove (directory destinazione per gli elementi cosa (selezioni) dove (directory destinazione per gli elementi cosa (selezioni) dove (directory destinazione per gli elementi cosa (selezioni) dove (directory destinazione per gli elementi cosa (selezioni) dove (directory destinazione per gli elementi cosa (selezioni) dove (directory destinazione per gli elementi 
selezionati)selezionati)selezionati)selezionati)selezionati)selezionati)selezionati)selezionati)selezionati)

         FinishFinishFinishFinishFinishFinishFinishFinishFinish


